CVE-2026-73263
KritikTeknik Veri (Otomatik)
- CVSS Skoru
- 9.9
- EPSS
- 0.7%
- CWE
- CWE-78
- KEV Durumu
- Hayır
Yayım tarihi: 12 Ağustos 2026
Prowler, bir bulut güvenliği platformudur. 5.36.0 sürümünden önce, Kubernetes sağlayıcı bağlantısı testi, config.cmd-path ve config.cmd-args içeren bir legacy gcp auth-provider ile kubeconfig_content kabul etti çünkü api/src/backend/api/v1/serializers.py dosyasındaki kubeconfig_contains_exec_auth yalnızca exec bloklarını kontrol ediyordu ve POST /api/v1/providers/{id}/connection, bunu prowler/providers/kubernetes/kubernetes_provider.py dosyasındaki config.load_kube_config_from_dict aracılığıyla yükledi, bu da kubernetes-python CommandTokenSource.token'un saldırgan tarafından sağlanan komutu paylaşılan işçi üzerinden subprocess.Popen aracılığıyla çalıştırmasına neden oldu. Bu sorun 5.36.0 sürümünde giderilmiştir.
Orijinal açıklama (İngilizce)
Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.
Referanslar
- https://github.com/prowler-cloud/prowler/commit/0b782fcb8c24ece7bd38deede2b8f13d8583e39c
- https://github.com/prowler-cloud/prowler/pull/12091
- https://github.com/prowler-cloud/prowler/releases/tag/5.36.0
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j
Bu CVE için henüz editoryal inceleme yapılmadı. Sadece otomatik teknik veri gösteriliyor.