CVE-2026-55546
KritikTeknik Veri (Otomatik)
- CVSS Skoru
- 9.8
- EPSS
- 0.4%
- CWE
- CWE-94
- KEV Durumu
- Hayır
Yayım tarihi: 25 Ağustos 2026
QWED-MCP, MCP için deterministik bir doğrulama geçididir. 0.2.1 sürümünden önce, src/qwed_mcp/engines/math_engine.py'deki verify_math_expression(), saldırgan tarafından kontrol edilen ifade ve claimed_result dizilerini, yalnızca Python üs söz dizimine normalize ederek, global_dict kısıtlamadan, Python yerleşiklerini kaldırmadan veya ifade AST'sini doğrulamadan doğrudan SymPy'nin parse_expr()'ine geçirir. parse_expr()'in Python'un eval()'ini yerleşiklerle birlikte çağırdığından, bu kamu kütüphanesi işlevine güvenilmeyen girişi geçiren bir saldırgan, Python import işlevselliğini kullanarak, qwed-mcp işlemi kullanıcısı olarak keyfi işletim sistemi komutlarını çalıştırabilir, erişilebilen verileri okuyabilir veya değiştirebilir, işlem gizliliklerini sızdırabilir veya dahili hizmetlere ulaşabilir. Varsayılan MCP araç kayıt defteri verify_math_expression()'i açığa çıkarmaz, bu nedenle sömürme, kütüphane API'sini saldırgan tarafından kontrol edilen girişle çağıran bir aşağı akım entegrasyonunu gerektirir. Bu sorun 0.2.1 sürümünde çözülmüştür.
Orijinal açıklama (İngilizce)
QWED-MCP is a deterministic verification gateway for MCP. Prior to 0.2.1, verify_math_expression() in src/qwed_mcp/engines/math_engine.py passes attacker-controlled expression and claimed_result strings directly to SymPy's parse_expr() after only normalizing caret syntax to Python exponent syntax, without restricting global_dict, removing Python built-ins, or validating the expression AST. Because parse_expr() calls Python's eval() with built-ins available, an attacker who can cause a downstream caller to pass untrusted input to this public library function can use Python import functionality to execute arbitrary operating-system commands as the qwed-mcp process user, read or modify accessible data, exfiltrate process secrets, or reach internal services. The default MCP tool registry does not expose verify_math_expression(), so exploitation requires a downstream integration that invokes the library API with attacker-controlled input. This issue is fixed in version 0.2.1.
Referanslar
- https://github.com/QWED-AI/qwed-mcp/commit/362e61892052e250c56cb1ee852024d6f98c467b
- https://github.com/QWED-AI/qwed-mcp/pull/22
- https://github.com/QWED-AI/qwed-mcp/releases/tag/v0.2.1
- https://github.com/QWED-AI/qwed-mcp/security/advisories/GHSA-mw6r-2hvm-4rp2
- https://github.com/QWED-AI/qwed-mcp/security/advisories/GHSA-mw6r-2hvm-4rp2
Bu CVE için henüz editoryal inceleme yapılmadı. Sadece otomatik teknik veri gösteriliyor.