CVE-2026-42271
Yüksek CISA KEV: Aktif İstismarTeknik Veri (Otomatik)
- CVSS Skoru
- 8.8
- EPSS
- 83.0%
- CWE
- CWE-77
- KEV Durumu
- Evet
Yayım tarihi: 8 Mayıs 2026 · CISA KEV son iyileştirme tarihi: 22 Haziran 2026
Etkilenen: litellm litellm
LiteLLM, OpenAI (veya yerel) formatında LLM API'lerini çağırmak için bir proxy sunucusu (AI Gateway) olarak görev yapar. 1.74.2 sürümünden 1.83.7 sürümünden önceki sürümlere kadar, bir MCP sunucusunu kaydetmeden önce önizlemek için kullanılan iki endpoint — POST /mcp-rest/test/connection ve POST /mcp-rest/test/tools/list — istek gövdesinde tam bir sunucu yapılandırmasını kabul etti. Bu, stdio taşıma tarafından kullanılan komut, args ve env alanlarını içeriyordu. Stdio yapılandırması ile çağrıldığında, endpoint'ler bağlanmaya çalıştı ve bu da proxy ana bilgisayar üzerinde proxy işleminin ayrıcalıkları ile sağlanan komutun bir alt işlem olarak oluşturulmasına neden oldu. Endpoint'ler yalnızca geçerli bir proxy API anahtarı ile sınırlı idi ve rol denetimi yapılmadı. Dolayısıyla, düşük ayrıcalıklı dahili kullanıcı anahtarlarına sahip olan herhangi bir authenticated kullanıcı, ana bilgisayarda任意 komutları çalıştırabilirdi. Bu sorun 1.83.7 sürümünde giderilmiştir.
Orijinal açıklama (İngilizce)
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Referanslar
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
- https://access.redhat.com/errata/RHSA-2026:27784
- https://access.redhat.com/errata/RHSA-2026:28960
- https://access.redhat.com/errata/RHSA-2026:30056
- https://access.redhat.com/security/cve/CVE-2026-42271
Bu CVE için henüz editoryal inceleme yapılmadı. Sadece otomatik teknik veri gösteriliyor.