CVE-2026-41268
KritikTeknik Veri (Otomatik)
- CVSS Skoru
- 9.8
- EPSS
- 17.4%
- CWE
- CWE-20
- KEV Durumu
- Hayır
Yayım tarihi: 23 Nisan 2026
Etkilenen: flowiseai flowise
Flowise, büyük bir dil modeli akışını özelleştirmek için sürükle ve bırak kullanıcı arabirimi sunan bir araçtır. 3.1.0 sürümünden önce, Flowise yetkilendirme gerektirmeyen kritik bir uzaktan komut çalıştırma (RCE) zafiyetiyle karşı karşıyadır. Bu zafiyet, FILE-STORAGE:: anahtar kelimesini NODE_OPTIONS ortam değişkeni enjeksiyonuyla birleştirerek parametre geçersiz kılma bypassı yoluyla sömürülebilir. Bu, containerize Flowise örneği içinde kök ayrıcalıklarıyla keyfi sistem komutlarının çalıştırılmasına olanak tanır ve yalnızca tek bir HTTP isteği gerekir, ayrıca örnek hakkında bilgi veya kimlik doğrulama gerekmez. Bu zafiyet 3.1.0 sürümünde giderilmiştir.
Orijinal açıklama (İngilizce)
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.
Referanslar
Bu CVE için henüz editoryal inceleme yapılmadı. Sadece otomatik teknik veri gösteriliyor.