← CVE Veritabanı

CVE-2025-24813

Kritik CISA KEV: Aktif İstismar

Teknik Veri (Otomatik)

CVSS Skoru
9.8
EPSS
99.9%
CWE
CWE-44
KEV Durumu
Evet

Yayım tarihi: 10 Mart 2025 · CISA KEV son iyileştirme tarihi: 22 Nisan 2025

Etkilenen: apache tomcat

Yol Eşdeğerliği: 'file.Name' (İç Dot) uzaktan kod çalıştırma ve/veya bilgi ifşası ve/veya yüklü dosyaların kötü niyetli içerik eklenmesine neden olan, yazma etkin Default Servlet aracılığıyla Apache Tomcat'te. Bu sorun, Apache Tomcat'i etkiler: 11.0.0-M1'den 11.0.2'ye, 10.1.0-M1'den 10.1.34'e, 9.0.0.M1'den 9.0.98'e. CVE oluşturulduğu sırada EOL olan ancak etkilenmiş olduğu bilinen aşağıdaki sürümler vardır: 8.5.0'dan 8.5.100'e. Diğer, daha eski, EOL sürümler de etkilenmiş olabilir. Aşağıdaki tüm koşullar doğruysa, kötü niyetli bir kullanıcı güvenlik duyarlı dosyaları görüntüleyebilir ve/veya bu dosyalarına içerik enjekte edebilir: - varsayılan servlet için yazma etkin (varsayılan olarak devre dışı) - kısmi PUT desteği (varsayılan olarak etkin) - güvenlik duyarlı yüklemeler için bir hedef URL, kamu yüklemeleri için bir hedef URL'nin alt dizini - saldırganın güvenlik duyarlı dosyaların adlarını bilmesi - güvenlik duyarlı dosyaların da kısmi PUT aracılığıyla yüklendiği Aşağıdaki tüm koşullar doğruysa, kötü niyetli bir kullanıcı uzaktan kod çalıştırma gerçekleştirebilir: - varsayılan servlet için yazma etkin (varsayılan olarak devre dışı) - kısmi PUT desteği (varsayılan olarak etkin) - uygulama Tomcat'in dosya tabanlı oturum kalıcılığını varsayılan depolama konumuyla kullanıyordu - uygulama, seri hale getirme saldırısında yararlanılabilecek bir kitaplık içeriyordu Kullanıcıların, sorunun giderildiği 11.0.3, 10.1.35 veya 9.0.99 sürümüne yükseltmeleri önerilir.

Orijinal açıklama (İngilizce)

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

Bu CVE için henüz editoryal inceleme yapılmadı. Sadece otomatik teknik veri gösteriliyor.